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ArcPro Training May 2023

Part 1: Adding and Displaying Data in ArcPro
Getting Data and Opening ArcPro

 ArcPro documents will use an .aprx suffix. On the main screen, choose “Start without a template” in the 
middle of the screen. Go to Insert ribbon and select New Map. Now click on the Map ribbon, click on the 
Add Data button in the toolbar and on the left side of the prompt window highlight My Groups. Click on 
the Groups subtab (next to Content) and double-click on the shared group folder MVRPC:ArcProGIS-Basics.  
You will add in the WegerzynGardens polygon feature layer, the MOTParcels polygon layer package, and the 
rkprogramming table. 

Navigating in ArcPro

Can you see the layers that were added? Maybe not. This is because the map has opened at a scale larger 
than the layers can show. The first thing we’ll need to do is zoom in to the area where the layers are located. 
Find where roughly Dayton, OH would be on the map, place your cursor there, and zoom in by using the 
scroll wheel on your mouse. One direction zooms in, while the scrolling the other direction zooms out. Aim 
for North Dayton. Note: the map may lag a few seconds while it resets the scale (this is normal). 

The layer names of what you added are shown on the left-hand side in the Table of Contents (TOC). You 
can turn the layers on and off by clicking the checkboxes next to their names in the TOC. Turn off (uncheck) 
MOTParcels. The layer is no longer visible in the map but it is still there. 

Move around the map by clicking and dragging a point on the map to pan around. This will change the view 
in the map without changing the zoom extent. 

To get closer to a layer without manually scrolling, use the Zoom to Layer feature. Right-click on Wegerzyn-
Gardens in the TOC and select Zoom to Layer. This moves the 
map’s extent to view the full extent of the selected layer.

Finding and Adding Other Data on AGOL

Sometimes data isn’t just in our own located folders or even in 
our own organization. Some layers outside our organization 
may be useful to add into a map. Return to the Map ribbon and 
click the Add Data button. On the lefthand side of the window, 
highlight the ArcGIS Online option under Portal. In the top right 
of the window, find the search bar and type in “gdrta”. Several 
options pop up. Find the Transit Routes option, but click the option Tran-
sitRoutes marked as a layer package (it’s icon looks like a yellow lego with 
the black asterisk). Click OK.

In the Table of Contents, find Transit Routes and right-click>View Metadata. 
ArcCatalog opens up and shows information about the layers, including 
source and any other information the author included. Here the summary 
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tells us about the layer and also see the use limitations. Once you’ve finished scrolling through the metadata, 
click the x next to ArcCatalog at the top to return to your map.

Go back to Add Data, then highlight the ArcGIS Online option again. In the search bar type in “dayton 
regional bikeways”. Click the option Regional Bikeways layer package (yellow lego with the black asterisk ). 
Highlight this option, then click OK. 

Bus Routes and Bikeways have now been added to the map.

Creating a Point Layer

We’ve added in layers from both our own group and outside the organiza-
tion but what about location data from tables? Here we’ll create a point layer 
showing the different program locations within Wegerzyn Gardens. 

In the Table of Contents (TOC),  right-click on the rkprogramming table to open 
it and view the fields. Notice that there are fields for bothX and Y coordinates. 
Close the attribute table by clicking the ‘x’. We will be using these fields to tell 
ArcPro where to create the points. Go back to the Add Data button at the top 
and click on the little down arrow next to it and select X Y Point Data. A new 
prompt opens on the right side of the screen. For the top dropdown, Input Table, 
select rkProgramming. For Output Feature Class, click on the folder icon and set 
the path location to save back in My Content. Name the output feature class ParkProgramInfo_[yourinitials]. 
For X Field, make sure the XLocCoord is selected and for Y Field, that the YLocCoord is selected. You may 
leave the Z Field blank. Click Run at the bottom of the screen. A new point feature class has been added to 
the map. 

Click on one of the points created of your choice. The point will be selected, highlighting it in blue, with an 
accompanying pop-up showing the information associated with that point. You can see which program this 
is referring to as well as the team lead. Click the x to close the pop up.
Save your map.

Displaying Data Exercises
Working with Basemaps

On the Map ribbon, click the down carrot underneath Basemaps. Select Imagery (one of the first at the top). 
The map beneath the layers changes to a satellite imagery basemap. Return to the basemap and select 
Imagery Hybrid-- now street lines and labels are drawn on top of the satellite imagery. Change it up and 
return to Basemap>Light Gray Canvas. The basemap style changes again. 

Look in the TOC. You will see two layers have been updated in regards to the basemap: Light Gray Reference 
is listed at the top, and Light Gray Base is listed at the bottom. Click off Light Gray Reference. The place names 
and street labels have been removed but the base layer (outlining shapes of areas and streets) still remains. 
Now continue to go through the basemap gallery and select the map that feels right to you. You are 
welcome to turn the reference layer (if applicable) on or off depending on your preference. Experiment!
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Symbolize Point Features

The x,y points created feature the default settings but these can be changed to 
different symbol shapes or colors. Right click on ParkProgramInfo_initials and select 
Symbology. Underneath the Single Symbol designation, click the symbol shape to 
open the gallery of presets and custom options. Make sure the Gallery subtab is under-
lined. Scroll through the options and first select the Triangle 1 option. Notice that it is 
automatically applied on the map; all points become black triangles. Scroll and select 
Star 3 instead. Leave the Star 3 option for now but scroll for a minute to see all the 
other options provided--there are many!

Next, change the color of the star by clicking on the subtab Properties (listed next to 
Gallery). Click on the box next to Color and select one of your choice. Click Apply at the 
bottom right to change it on the map. 

Next look at the outline color and change it to a color similar to the one you selected 
but slightly darker or lighter. Set the outline pt thickness to 1.25 by manually typing it 
in the box provided.

Save your work!

Symbolize Regional Bikeways

Now to differentiate the bikeway lines so they have a different treatment than the 
bus routes. Change up the RegionalBikeways layer by right-clicking on its name in 
the TOC and selecting Symbology. Midway down the pane, underneath a tab called 
Classes, is the symbology broken out by status. Click the Green line corresponding 
to Existing. Make sure the subtab Gallery at the top of the pane is the active window 
(instead of Properties). Scroll to find the Ferry preset style and click on it. The map 
automatically updates. Next, click on the Properties subtab. Click on the box next to 
Color and select Color Properties. Here instead of selecting a preset color, we’ll use a 
custom RGB value. In the Red value box, manually highlight the existing value and 
type 0. In the Green box, delete the existing value and type in 81. In the Blue box, 
delete existing and type 131. Keep transparency at 0% and click OK. Change the line 
width box to 1.5 pt. Click Apply.

Symbolize Parcel Layers

In the TOC, check the box next to MOTParcels to turn the layer back on. Right-click on 
MOTParcels>Symbology.  Underneath the Primary Symbology header, click the down arrow by single 
symbol and select Unique Values. In the Field1 dropdown, find and click LandUse. The map automatically 
updates with the default color palette. Play around with the different options. Because the data we’re 
mapping is different categories of land use, it is best to select a palette that has different colors for each 
parcel type, rather than different shades of a single color. Save your work.

Because LandUse has different cartographic standards for colors lets manually change each one to reflect 
the proper standard. Still in the Symbology Pane, look toward the middle underneath the the subtab Class-
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es. Each category has a box listed. A here means agriculture, so it should be 
changed to a light green color. Click once on the color rectangle symbol next 
to A. The Galleries/Property pane appears. Go to the Properties subtab and 
in the color box, find a lighter green that you like. Click Apply to reflect the 
changes. 

Return to the primary symbology page by clicking on the arrow in the circle 
icon at the top left of the Symbology Pane. Click once on the color rectangle 
symbol next to C. The Galleries/Property pane appears. Go to the Properties 
subtab and in the color box, find a brighter red that you like. Click Apply to 
reflect the changes. 

Repeat this process for the last 3 letters, selecting a blue color for Education 
(E), an orange color for Industrial (I) and a yellow color for residential (R). Save your work. 

For clarity’s sake, rename the Map. In TOC, right-click on Map>Properties. In the new prompt, select General 
on the left side. In the Name box, delete out Map and type Park. Click OK. 

Part 2: Configuring and Mapping Data in ArcPro
Configuring: Selecting Out Residential Areas

The park program plans to advertise by sending out postcard mailers to homes in the near vicinity but needs 
to generate a list of possible locations without wasting money by sending it to businesses. A Definition 
Query will set a filter to restrict what shows up by parcel category.

In the TOC>right-click on MOTParcels layer> Properties and on the left-hand side of the prompt, find and 
select the Definition Query tab. Click New Definition Query in the middle of the box.  Select LandUse in the 
Where dropdown first box. In the middle box, keep/select “is equal to” and in the third dropdown box, select 
R. Click Apply.  Click OK. You now see that only the parcels marked residential remain showing in your one 
data frame.

Configuring: Remove Proposed Bikeways

Using Definition Query again, we’ll remove the Proposed Class designation of bikeways since these are not 
technically created and would confuse the reader. In the TOC> right-click on RegionalBikeways layer> Proper-
ties and on the left-hand side of the prompt, find and select the Definition Query tab. Click New Definition 
Query in the middle of the box.  Select STATUS in the Where dropdown first box. In the middle box, keep/
select “is equal to” and in the third dropdown box, select Existing. Click Apply.  Click OK. Proposed bike 
lanes have been removed from the map.

Configuring: Creating a Buffer

While residential parcels are the only ones remaining, there are still far too many to send out a mailer. The 
next part will create a buffer (or circle around) of a quarter mile from the park to include only homes in the 
closest vicinity to the park. At the top of the ArcPro screen locate the Command Search box and type in 
Buffer. A list of possible tools is shown. Click the one with a hammer icon labeled Buffer (Analysis Tools). A 
new prompt window on the right opens up. In the Input dropdown, select WegerzynGardens. For output 
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location, click the folder icon and decide where to save it (the default is a geodatabase within your .aprx 
project. For today, save it to the desktop.) and name it BufferQuartermile. Make the distance 0.25 and select 
Miles in the Unit dropdown. Keep the other remaining defaults. Click Run. A quarter-mile buffer around the 
gardens is generated.

Configuring: Locating Parcels Within the Buffer

Click on the Map ribbon>Select by Location. In the Input dropdown, in the top dropdown selection box, 
choose MOTParcels. In the Relationship dropdown, select Within. In the Selecting Features dropdown, 
choose BufferQuarterMile. Click Apply and let it run. Click OK. Residential parcels that fall within the buffer 
have been highlighted. Uncheck (turn off) the BufferQuarterMile in the TOC.

Making a Table
To generate the list for the mailer, the next step is to export it out. Still with the MOTParcels highlighted, go 
to the TOC> right-click on MOTParcels layer> Data>Export Table. For Output Location, click the folder icon 
and point it to where you’d like to save the table (in this case, save it to the desktop of the machine) Click OK. 
For Output Name, type in ParkMailerAddresses. Click OK. In the TOC, turn back off the MOTParcels layer

A .dbf table is created that is added back into the map project. Note: if you wanted to save it as an excel 
document, open a blank Excel spreadsheet and click open. Make sure the “All Files” option is selected and 
click on the ParkMailerAddresses dbf version. When it opens, go to File>Save as and save out as a  .xlsx.

Working in Layout View- Mapping Elements

Go to the Insert ribbon (third tab across at the top). Select New Layout, 
and then find the ANSI-Landscape section and select Letter. Still in 
Insert ribbon select Map Frame>and the second option (NOT the default view).   
The Layout view appears--this is showing map elements organized on the page designed for map printing. 
Click and drag a large rectangle on the piece of paper (you can always adjust the size later).  Now to add sur-
rounding elements:

North Arrow
Go back to Insert ribbon. Look in the Map Surrounds group, click North Arrow and insert a north arrow of 
your choosing and click and drag it on the page. Right-click on the arrow and click Properties-- in the right 
hand panel, select the 3rd icon, Placement. Set the height to be 0.5in. Click and drag the north arrow to the 
top right corner of the mapped area.

Scale Bar
Click the Insert ribbon at the top of ArcPro. Look in the Map Surrounds group, click Scale Bar. Select one of 
your choosing from the Imperial selections. A cross arrow appears. Click and drag anywhere in the white 
page to create a scale bar (you can change size later, so don’t worry too much about getting it perfectly right 
the first time).

On the right hand side the format box is open-- if it is not double click on the scale bar to open. Click the 
second icon at the top where hover text reads properties. Use this box to manually adjust the divisions and 
subdivisions of the bar (stick with something less than 4) When finished, click the scale bar and drag it to just 
below the bottom left corner of the mapped body. 
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Legend
Now to add a Legend. Go back to the Insert ribbon at the top and Find the Legend dropdown. Select 
the Legend 1 style. (If a legend dropdown is not available, select the legend symbol and click and drag 
somewhere in layout view for one to appear). Somewhere in the Layout View, with the new crosshair, click 
and drag to create the legend. If an orange ellipsis shows up, you did not draw the box large enough. To 
make it larger, click and drag the corners until the ellipsis disappears. Once the Legend is created, go to the 
right-hand side to see the properties. In the middle of the Options Pane,  find the Title section in the middle 
of the Options (default) pane, find the box marked “Show” and uncheck it. 

Next we will remove the bikeways item in the legend without removing it 
from the map. Still in Layout View, look on TOC. Under Drawing order, find 
the Layout map and turn the left triangle to reveal the layers listed. Under 
the Legend subtab, find RegionalBikeways and uncheck the box next to it. 
Leave it checked in the lower level Map Frame section.

The legend still shows the transit lines as having a couple different catego-
ries that are true for the layer, but not for the extent we are using for the 
map, so we will remove the GreeneCATS from the legend. Still in the Options 
pane on the right side, find the Legend Items carrot and make sure it is 
turned down. Click on Show Properties button. Towards the bottom of the 
pane, find the Feature Display Options section (turn down the carrot if it is 
not already) Check the box for “Only show features visible in the map extent”. 
The GreeneCATS item in the legend disappears.

Still in the Legend Items pane, in the Show subsection above, uncheck the 
Layer Name and Heading boxes to remove more unnecessary text in the 
Legend.

Lastly, we need to clean up the names of the items. Instead of ParkProgramInfo_initals, change the name to 
Program Areas. Back in the Table of Contents on the left, click once on ParkProgramInfo_initials text and then 
type Program Areas. Save your work.

Change the symbology shape for Wegerzyn Gardens beyond just the straight line box. 
Click back on your map tab and in the TOC, right-click WegerzynGardens>Symbology. 
Midway down, beneath the Classes tab, click on the carrot of the polygon symbol and 
select a shape of your choice, whether it’s ellipse, boundary, or natural body.

Adding an Inset Map
Adding an inset map can require two map frames—the map frame containing the 
overall area and the map frame with the extent you want to show. Go back to the 
Insert tab and select New Map this time. Go to the Map ribbon and select the Add 
Data button and add in the DaytonBoundaries layer from the online Group folder. 
Right-click on DaytonBoundaries in the TOC and select Zoom to Layer. 

Return to the Layout tab. Still in Insert ribbon select Map Frame>and find the options under the Map 1 
heading. Select your custom (not the default ) extent. Draw another map body in the lower right corner 
on top of your existing map frame.  Rename this map frame NorthDayton (right-click on Map Frame 1 in 
TOC>Properties and type in North Dayton.) In the Format Map Pane on the right, click on the Placement 
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Icon (the fourth one) to resize it to be 2 inches wide by 2 inches tall. Repoint the data back to the layer’s 
extent by going to the TOC and right-clicking DaytonBoundaries>Zoom to Layer. 

Altering Basemap Credits Text
Still in the Insert ribbon, click on Dynamic Text logo’s carrot dropdown and scroll to the Layout section and 
select Service Layer Credits. This brings up a crosshair with a small capital A for you to click and drag for 
approximate size-- make a small box contained in the bottom of the Inset map. The credits from both maps 
have disappeared and are shown together in this box, even if two different basemaps are used. Format this 
text by going to the right-hand pane Format Text. Click the subtab Text Symbol, click the carrot next to Ap-
pearance to show the options, and select the smallest font size- 6pt. Click Apply. Go back to the credits, click 
once and resize by clicking and dragging so it is now a long small string that will run along the bottom right 
corner of the map. Click and move your Inset map to reposition it just above the credits text.

Inserting Static Text
Once again go to Insert ribbon then find the Graphics and Text subsection. Find a little capital A where the 
hover text reads “Straight Text,” and click once. This brings up a crosshair with a small capital A for you to click 
and drag for approximate size. Point it somewhere in the Layout View where you will want the Title located 
and click and drag. The word ‘Text’ appears, larger the larger you click and dragged. The Format Text pane 
on the right appears. (If it doesn’t double-click the word text to get it to appear). In the middle of the pane, 
highlight the word “text” in the white box and change the Text to “Wegerzyn Park Program Locations” 
(make sure to delete the word ‘Text’).Click outside the pane to enact the change.

Highlight the text you just typed and click the Text Symbol subtab at the top of the pane. Here is where to 
alter font and size. Keep the Font Tahoma, but change size to 18pt. Next, to center the text, go to the top 
Format ribbon surrounded in blue on ArcPro and find the Arrange subgroup. Click on Align. Make sure to 
click on the Positions’ (the set of 9 small white squares)top middle 
box to turn it blue, as shown in the accompanying photo. Go 
back to the Format tab and click on Align and turn on the bottom 
selection Align to Page. Click on Align> Align Center. (Note: this 
section can be a bit tricky. Make sure the title text is not highlighted when you go to the Align section, 
otherwise the Align to Page will be grayed out.)

Now to identify the Inset map. Add a new straight text box somewhere to your layout view. Double-click 
the word “Text” and type in Dayton Area. Click and drag the cursor over the text to highlight it. Click the Text 
Symbol sub tab at the top of the pane, then turn the carrot down by Appearance and select 11 pt font. Make 
it italic. Click Apply. Drag it to the top left corner of the Inset map frame.

Setting up an Extent Indicator
Extent indicators are a way to show the extent of one map frame within another map frame. They are often 
used for layouts containing locator or overview maps. A locator map shows a larger area, or extent, than the 
main map to provide spatial context. An extent indicator can be added to the locator map to show the area 
represented in the main map. This next section outlines how to create one. 

On the Insert tab of the ribbon, in the Map Frames group, click the Extent Indicator button. A drop-down 
menu appears listing the remaining map frames on the page. Choose the Park Map frame as the map to 
show the extent (as there are only two maps, it is the default choice). An extent indicator draws on the map 
frame.
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Select the extent indicator in the TOC, right-click and choose Properties to open the Element pane. There 
you can change the symbol fill color to no color, the symbol outline color to red and the outline width to 
4pt. Click Apply. Save your map!

Labeling Select Features

Map elements look good but we have a couple more items to finalize to polish 
it off. 

Label the transit routes and the program area locations. At the top of the 
ArcPro window, click back on the Map tab (instead of Layout). Right-click on 
TransitRoutes>Label. The bus route number appears. Now to create a layer 
symbol for the routes. Look at the top of ArcPro and find the Labeling ribbon 
tab (between Appearance and Data, see above picture). Find the Text Symbol 
subgroup, and click the Text Symbol Style down carrot with line over the top to 
see the full menu of options. Scroll to the Shield subsection, then select Shield 
14. Route numbers are now on the bus lines themselves and much easier to 
read with the contrast behind them.

In the TOC, right-click on Program Areas>Label. A label turns on but it is not the field we want. Back in the 
TOC, right-click again on Program Areas>Labeling Properties.  In the Class subtab, in the white box in the 
middle, highlight and delete the text inside. Above the box, in the Fields box, scroll carefully to find Name 
and double click to insert it into the white box. Click Apply. Labels have been updated to show the name of 
each section.

Label Placement

ArcPro has a lot of customization options to really fine tune label place-
ment. We’ll explore this through the Transit Route labels. In the TOC, right-
click again on TransitRoutes>Labeling Properties. Click on the Position 
subtab. The first icon (with hover text Position should be opened. If not, 
make this the active pane). Under the second dropdown in the Placement 
section, select Centered Horizontal. Time permitting, check out a couple of 
the other styles to see what’s available and how it gets changed between 
Centered Curved vs. Centered Horizontal vs. Offset Horizontal.

Still in the Position subtab, click the third icon over with the hover text 
Conflict Resolution. Turn the carrot down next to Remove duplicate labels 
and open the dropdown. It contains three options--review them. We don’t want to remove all of them but 
we don’t want to keep it the way it is. Pick the middle option Remove from a fixed distance. 
The search radius lets you customize how far apart Pro should look to remove extraneous labels. In this 
instance. Manually type in 2500 and select the units  dropdown to Map Units. Uncheck the box next to Prefer 
label near map border and instead check the box next to Prefer label near junction. Label repeats have been 
reduced.
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Exporting Map
Once you have completed the map to your liking, it’s time to export it. Go to the Share tab at the top and 
find the Output subgrouping. Click on Export Layout. Layout pane on the right hand side opens up. In the 
top File Type dropdown are listed different options. Make sure PDF is selected, then click the folder icon near 
Name to point where the program should save the pdf. (Point it to your desktop, thumb drive, or some other 
place that is accessible to you).

You can use this same method to export it as a .jpg, or a .png--just make sure to find that format and select 
that type before moving on to the Name to save it out.

Click Export at the bottom. 

Sharing Data Online
At the top of ArcPro, click the Share ribbon>web map. Name the map WegerzynTraining and include a 
sentence in the mandatory Summary block about this being a test for training purposes. In tags, type “train-
ing”, and decide which folder to save it to; remember this will be in your AGOL page, so if you have a training 
folder or just a basic content page, that might make the most sense. If doing this for a real map, you would 
check the level of boxes for your organization or for Everyone, but for today leave both blank. Click Analyze 
and then click Share.

If you have questions regarding this training later, please reach out to Tom Harner at: tharner@mvrpc.org or 
Kathryn Youra Polk at: kyoura.polk@mvrpc.org


